Discussion:
upgrade gfxcard -> radeondrmfb nightmare
(too old to reply)
Felix Miata
2014-08-23 08:33:32 UTC
Permalink
Raw Message
I didn't really expect to, since they look like kernel modules, and I really
only have a problem with the latter.

I bought a $30US HD5450 (Evergreen) Radeon so I'd have some non-Intel gfxchip
newer than 7 years old here. It will have cost $15 net once I claim the
available rebate. I first tried it in a 32 bit i915G system after freshly
updating 12.3, 13.1 and 13.2. Everything worked as expected in all three,
then I put in the Radeon, and tried first 13.2. Init progressed for about 20
seconds, then announced "switching to radeondrmfb from VESA VGA", and
promptly stopped updating the screen. From there I experimented a bit and
figured out I can keep video working by eliminating both vga= and video= from
cmdline, but that's not OK here.

I pulled the card back out, then updated 13.1 and 13.2 on a 64 bit Intel 4000
system that already had Radeon, an older X600. After determining everything
works as expected on 12.3, 13.1 and 13.2, I swapped the 5450 into the X600's
slot. Everything works as expected with it too.

So, I undid the swap, put the newer system back on the shelf, and put the
5450 back into the i915 system. I tried 13.1/Jiri's 3.12.22 kernel, but same
problem. Next, 12.3, no problem. Next, 13.1 again, but with 3.11.10, and
video stays working.

Rawhide/3.17rc1git2 on the 915 system with 5450 card finds the radeondrmfb
during boot and works as expected. Lsmod there shows drm_kms_helper and
radeon and ttm for drm.

In 13.1 remote login I see this excerpt in dmesg:
[ 22.500935] r600_cp: Failed to load firmware "radeon/CEDAR_pfp.bin"
[ 22.500957] [drm:evergreen_init] *ERROR* Failed to load firmware!
[ 22.500973] radeon 0000:01:00.0: Fatal error during GPU init
[ 22.500987] [drm] radeon: finishing device.
[ 22.508073] [TTM] Finalizing pool allocator
[ 22.508142] [TTM] Zone kernel: Used memory at exit: 0 kiB
[ 22.508157] [TTM] Zone highmem: Used memory at exit: 0 kiB
[ 22.508164] [drm] radeon: ttm finalized
[ 22.508688] radeon: probe of 0000:01:00.0 failed with error -2

Searhing for string radeondrmfb in Novell Bugzilla turns up nothing.
Searching for *drm* in /lib/modules I see no differences in names for 3.11
and 3.12. Searching with zypper for irmware I see nothing that looks like
it's for ATI or Radeon or any installed kernel. Remote login is broken for
13.2. I tried without proper cmdline to install 3.17rc1vanilla in 13.2, but
initrd creation failed (and yet do_purge_kernels got created). At that point
I uninstalled vanilla, and tried installing kernel-firmware. That worked,
after 5 hours of head banging. :-(

Why this impediment to upgrading gfxcards in openSUSE? Shouldn't
kernel-firmware have already been installed? Why do only some gfxchips need it?
--
"The wise are known for their understanding, and pleasant
words are persuasive." Proverbs 16:21 (New Living Translation)

Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata *** http://fm.no-ip.com/
Loading...